24
14
6
3
0
Büyük hatalara sahip uygulamalar için zorunlu güncelleme seçeneği projesi deneme aşamasında.

Google Android Dev Summit (Android Geliştiriciler Zirvesi) etkinliğinde mobil işletim sistemleri için yeni araç ve özelikleri duyurdu. Bunlardan birisi tabii ki de Android geliştiricilerinin arasında yaygın olan, son çıkan Kotlin dil desteği oldu. Bunların yanı sıra Android Jetpack için yeni araçlar ve API’ler (Uygulama Programlama Arayüzü) de duyuruldu. En büyük sürpriz ise Uygulama İçi Güncelleme API’ı oldu.

İsmi büyük bir yenilik değilmiş izlenimini verse de fazlasıyla büyük bir yenilik. Yeni API ile geliştiriciler kullanıcılarına uygulamalarını güncelletmek için yeni yollar ediniyorlar.

Korkunç bir hata bulunan bir uygulama yayınladığınızı düşünelim. Fazlasıyla olası bir durum... Artık bu durumu düzeltmek için uygulamaya tam ekran bir engel mesajı koyabilir ve uygulamayı güncellemesi için kullanıcıları zorlayabilirsiniz. Tabii ki bu yalnızca gerçekten ciddi hatalar için geçerli. İkinci seçenek ise güncelleme yüklenirken kullanıcıların uygulamayı kullanabilmesine imkân tanıyan bir yöntem. Geliştiriciler bu güncelleme akışlarını tümüyle düzenleyebilecekler.

Şu an için yeni API güncellemeleri test aşamasında ancak yakın zamanda hayata geçirilmesi planlanıyor.

Kaynak : https://techcrunch.com/2018/11/07/android-developers-can-now-force-users-to-update-their-apps/
24
14
6
3
0
Emoji İle Tepki Ver
24
14
6
3
0