Google, Tüm Uygulama Güncellemeleri İçin Android 10 ve Üzeri API'leri Zorunlu Kıldı

138
26
14
12
5
Google Play uygulama güncellemeleri için Android 10 API hedeflemesi zorunlu oldu. Artık tüm yeni uygulamalar ve uygulama güncellemeleri Android 10 ve daha yeni API'leri hedeflemek zorunda.

Android işletim sisteminin ‘patronu’ konumunda bulunan Google, Google Play için tüm uygulamalar için hedef API seviyesini güncelledi. 3 Ağustos’tan itibaren yayınlanacak tüm yeni uygulamalar için Android 10 (API seviyesi 29) ve üstünü zorunlu kılan Google, şimdi ise aynı gereksinimi uygulama güncellemelerine getirdi.

Android ekosistemi, devasa bir aktif cihaz sayısına sahip olduğundan Android 10’un işletim sisteminin en popüler sürümü olmasının kolay olmadığını ifade edebiliriz. Yine de Google’ın Android cihazların daha hızlı güncellenebilmesi için yayınlamış olduğu Project Treble, Android 10’un en hızlı ‘yükseltilen’ Android sürümlerinden biri olmasını sağladı.

android 10

Google, Android 10 ile birlikte geliştiricilere katlanabilir akıllı telefonlar için destek, 5G, karanlık tema ve gelişmiş gizlilik özellikleri gibi pek çok yeni API sunmuştu. Bu nedenle Google’ın geliştiricilere hedef olarak Android 10’u zorunlu kılması, uygulamaların gelişimi açısından da büyük önem taşıyor.

Özellikle popüler uygulamaların çoğu Android 10 API’sine zaten geçiş yapmış durumda. Ancak henüz API güncellemesi almayan bazı uygulamaların risk altında olduğunu söyleyebiliriz. Bununla birlikte Google, geliştiricilere bir önceki Android sürümünü zorunlu kılarak güncel API’lerin benimsenme hızını artırmayı ve geliştiricilerin kullanıcılara daha iyi bir deneyim sunmasını zorunlu kılmayı hedefliyor.

Kaynak : https://www.xda-developers.com/all-apps-google-play-required-target-android-10-api-level-29/
138
26
14
12
5
Emoji İle Tepki Ver
138
26
14
12
5